VXM-175VFi用の動画

VXM-175VFiで再生する動画を作るための覚書


VXM-175VFiの仕様では再生できる動画は次のようになっている。

ビデオコーデック:MPEG4/H.264、拡張子:MP4/M4V,ファイルサイズ:1GB以下
対応プロファイル:Simple Profile Level 3まで
最大解像度:720×480、フレームレート:15/30fps、ビットレート:216k~4Mbps
オーディオコーデック:AAC-LC
サンプリングレート:16/22.05/24/32/44.1/48kHz、ビットレート:8~320kbps


ソフトはNV-SB540DTの時と同じ『XMedia Recode 2.1.4.8』を使うものとし、以下のように設定する。

「形式」タブ
  プロファイル:カスタム
  形式:MP4
  ビデオコーデック:MPEG4
  音声トラック1コーデック:AAC
  音声トラック2コーデック:AAC
  音声/ビデオの同期:ON
  出力ストリーム:ビデオ+音声

「ビデオ」タブ
  言語:なし
  フレームレート:30
  レート調整モード:平均ビットレート
  ビットレート:取り敢えず1000(「リスト」タブでファイルサイズを確認しながら調整する)
  GOP長さ:15
  カラーモード:YUV 4:2:0 Planar
  グレイスケール:OFF
  Deinterlace:OFF
  Trellis:OFF
  ビデオコピー:OFF

「音声トラック1」タブ
  音声トラック:1,AAC 0 ビットレート 2チャンネル(1,MP3 0 ビットレート 2チャンネル でも可)
  言語:なし
  サンプルレート:44100
  レート調整モード:平均ビットレート
  ビットレート:128
  チャンネル:Stereo
  MPEG Version:MPEG-4
  オブジェクトの種類:LC(Low Complexity)
  出力形式:ADTS
  ローパス:0
  音量補正:音量変更
  音量:100
  TNS:OFF
  Mid/Side:OFF
  音声コピー:OFF

「音声トラック2」タブ
  音声トラック:なし
  以下の項目は設定不要

「クロップ/プレビュー」タブ
  解像度
    幅:720
    高さ:480
    スケーリングモード:Bicubic
    アスペクト比:3:2
    拡大:なし
    正確なアスペクト比:OFF
    アスペクト比を保持:OFF
  追加(元映像によって異なる→後述)
    上:
    下:
    左:
    右:
  上記以外は設定なし

「タグ」タブ
  全て空白


アスペクト比の問題

VXM-175VFiの画面はNV-SB540DTと同様に縦横のドットピッチが1:1でないことは取説に載っている。
画面についてメーカーに問い合わせたところ、解像度については800x480との解答を得たがドットピッチの縦横比については解答を得られなかった。
画面を実測してみたら物理的アスペクト比はおよそ1.962:1となっている。
自然な映像にするにはこの差異と元動画のアスペクト比を考慮して余白を追加する必要がある。

この追加する余白を何ピクセルにするかは元の映像で異なるのでこのページで算出する。

| | コメント (0) | トラックバック (0)

劇遅のWindowsUpdate

昨日の午前中、Windows7のノートPCで久しぶりに(といっても2ヶ月も経ってないと思うけど)WindowsUpdateをかけたら「更新プログラムを確認しています」の状態のままいっこうに進まない。
そのまま放置しておいたら、今日の午後になってようやく一覧が出てきた。その数約30個。
なんと30時間弱もかかったよ。(-_-)

| | コメント (0) | トラックバック (0)

PCセットアップ中にWindowsアップグレード発動(-_-メ

新PCにWindows7をインストールしてWindowsUpdateを実行。その後、アプリケーションのインストールやら各ソフトの設定やらセットアップ作業をしていたら突然Windows10へのアップグレード処理が始まってしまった。このタイミングでそれは無いだろう。(´_`)

途中でキャンセルしたけど、新PCに最初からゴミが混入していては気分が悪いので一からやり直すことにした。今度はWindowsUpdateは実行せずに。

で、全てのアプリケーションのインストールが終わった後にWindowsUpdateを実行。数時間経って一覧に出てきたのは200個超。(^_^;
よくよく見てもWindowsアップグレードに関するものが無かったのでIE以外を全て適用。
IEのバージョンアップ以外の更新情報がなくなるまで繰り返してやっと完了。この間、Windowsアップグレードに関するものは無し。

どうもIEのバージョンがWindows10へのアップグレード条件の一つになっているような気がする。
と言うのも、旧メイン機をずっとIE8のままで使っていたけど、何時になってもGWXのアイコンが表示されないので何故だろうと不思議に思っていた。
それがある日、何気なしにIEを11に(9と10は飛ばして)更新したとたんにGWXが現れたからだ。
で、今回のセットアップでIEのバージョンアップを避けてきたが、結局GWXは現れていない。

| | コメント (0) | トラックバック (0)

新PCケース SHA-T3W

i7-4790Kはかなり発熱するらしい。なのでCPUクーラーは冷えると評判の虎徹を付けることにしたのだが、このクーラーはかなりでかくて高さが160mmもある。
また、設置場所の関係から高さが430mm以下でスイッチ類がなるべく低い場所にあるケースでなければならない。

この条件で探すと選択肢がかなり限れるが、その中からSHA-T3Wというケースを選んだ。
少し心配だったが虎徹も収まり、前面のファンが光ってけっこう良い感じ。

しかし、ちょっと残念な点も。ケース上部にあるLEDのケーブルがペリフェラルコネクタになっていて電源に直結するしかない。これではPCをスリープにした時に消灯してしまってスリープ状態なのか電源オフ状態なのかわからない。

何か無いかと過去のPCの遺物を漁ってみたらファンかなにかのコネクタが見つかった。
このコネクタ、突起部分を削るとマザーボードのPOWER LEDピンにぴったり。
で、このコネクタと別にあまっていたペリフェラルコネクタで中継ケーブルを作成。

この中継ケーブルを介してケースのLEDのケーブルをマザーボードのPOWER LEDピンに挿すことでスリープ状態の時にはLEDが点滅するようになった。

| | コメント (0) | トラックバック (0)

久々のPC組み立てでハマった

6年半ぶりにPCを組み立てた。

CPUはi7-4790K。i7も今では6世代目が出ているけど、6世代目以降のi7だとWindows7のサポート期間が短縮されるらしい。私はなるべく長くWindows7でいきたいし、5世代目は電力消費量が高そうだし。定格4Gなら当分の間は使えるだろう。
マザーボードはASUSのH97-PLUS。オーバークロックも出来るようだし(当分やるつもりはないけど)、何よりPS/2ポートが二つある。最近は一つしかないものが多いようだけど私には二つ必要なのだ。
ビデオカードは現メイン機からGTX660のカード(例のファンが壊れたやつ)を移植して、現メイン機には宙に浮いていたGTS250のカードを移植する。
GTX1080のカードが5~6万なら買いたいけど、さすがに10万は無理。
メモリは8Gx2の16Gとした。

で、ハマってしまった。(^_^;

H97-PLUSのマニュアルにはメモリ2枚挿しの時にどのスロットに挿せとの明記がない。ググってみたらH97-PROのマニュアルにはA2とB2に挿すように書いてあるとか。
でも普通に考えてA1とB1だろうと思った。一応P7P55Dのマニュアルを見るとA1とB1に挿すように書いてあるし。
で、A1とB1に挿して電源投入。ちゃんと16Gと認識している。Windows7をインストールしてマイコンピュータのプロパティを見ても16Gとなっている。

まぁ、そりゃそうだろうと思っていたら思わぬトラブルが発生。
ビデオカードを認識しない。カード付属のディスクからドライバをインストールしても解像度が上がらない。再起動してもフリーズしたりして全く安定しない。
ビデオカードが移植のショックで壊れたかとか相性問題かとか不安になってきた。
ビデオカードの購入も頭をよぎったが、もしやと思ってメモリをA2とB2に差し替えてみた。
するとなんと、解像度も上がり安定して動くようになった。

結局、メモリ2枚挿しの時はA2とB2に挿すのが正解だったようだ。
でも、番号が若い方から挿すのが普通だろう。ちゃんとマニュアルに書いておいてくれないと困るよ。

| | コメント (0) | トラックバック (0)

Google Driveがクラッシュ?

時々、Google Clomeを閉じた直後にGoogle Driveがクラッシュしたとメッセージが出てくるようになった。
クリックしても何もおこらないし、すぐに消えてしまう。
Google Driveなんてインストールしてないのに、何だろうこれ。


| | コメント (0) | トラックバック (0)

ビデオカードが壊れた そして復活

フライトシミュレーターを始めると、間もなくして画面が消えてPCが再起動するようになってしまった。
PCケースのカバーを開けてみたらビデオカードのファンが回っていなかった。

GTX660を積んだPALITの製品で、PCの電源投入直後は回転するものの直ぐに止まってしまう。
この動画と似た状況だ。
ただ向こうは回ろうとしている感はあるけど、うちのはまったく無反応。

それでもWebブラウジングなど普通の操作には特に問題はない。カード付属のユーティリティーを開いてみるとコア温度の上昇も極僅か。

一時はビデオカードの交換も考えたけど、ファンだけの問題なので少ない出費で何とか出来ないかとやってみた。

電源投入時には回転するのでカードのファンコントローラーの問題だろうと判断して、ファンケーブルを直接電源に繋ごうと思ったらコネクタの形状が合わずそのままでは繋げない。
電源側のピンを細工して挿したり抜いたりしていたら、電源投入時も回らなくなってしまった。(^_^;

仕方が無いのでファンを交換することにした。
元々のファンはカードのカバーに3本のステーで直付けされているのでこれをぶった切って、買ってきた80mmの薄型ファンをネジ止めで装着。
本当はもう一回り大きいファンにしたかったのだけど薄型のものが置いていなかった。

しかし、この薄型ファンでもそのままではヒートシンクに当たって基盤に装着できない。
そこで、ネジ穴の所に長さ1cmに切ったアルミ管をかまして基盤と無事合体。

フライトシミュレーターを起動してビデオカードの状態をモニターしてみると、コア使用率95%程度、コア温度60℃で安定している。
GTX660が何度位まで安定動作するのか分らないが、暫くこのまま使ってみてまたトラぶったらカード交換かな。
その時はPALITのはやめよう。

| | コメント (3) | トラックバック (0)

スマホ I/Oエラー (>_<)

スマホとPCをUSB接続して、PCからスマホのmicroSDにファイルを転送しようとしたらI/Oエラーが出てしまった。
一旦外して再度接続すると「ファイルが壊れている可能性があるので修復するか?」みたいなメッセージが出てきたので実行してみたらエラーで落ちてしまった。

原因として考えられるのは、microSD、USBケーブル、PCのUSB端子、スマホ本体の何れか。まぁ一番怪しいのはmicroSDだが。

手っ取り早くPCの別のUSBポートに挿してやってみる→NG。サブPCでやってみる→NG。どうやらPC側の問題ではなさそう。次はUSBケーブルを変えてみたいところだがmicroUSBケーブルはこれ一本しかないから出来ない。

と言うことで次は本命のmicroSD。スマホから取り出してPCのカードリーダーに挿したらまた「ファイルが壊れている・・・」と出てきたので実行する。今度は最後まで行ってエラーは見つからなかったと言う。microSD内のデータをPCにバックアップするが特は問題はない。

microSDをスマホに戻し、microSDにインストールしてあるアプリを本体に移動させて初期化。その後再度PCと接続してバックアップしたデータを戻してみる。またエラー。(-_-メ

またmicroSDをPCに持っていってPCで完全フォーマット。スマホに戻してスマホでも初期化。そしてPCと接続してファイルを転送。今度はエラーも出ずに完了した。本体に退避させたアプリをmicroSDに移して普通に動いている。このまま再発しなければ良いが。

それにしても何故本体の裏蓋を外さないとmicroSDを取り出せないようになっているんだろう。W-ZERO3[es](これはminiSDだが)みたいにカバーを開閉して簡単に取り出せるようになってると楽なのに。

| | コメント (0) | トラックバック (0)

Windows7でFrontPage Expressを使う

Windows95か98に付いていたhtml編集ソフトのFrontPage Express。
高度なページを思い通りに作るのは難しいかもしれないけど簡単なページならこれで十分だし、余計なタグを含まず簡潔なhtmlを吐き出してくれるので雛形を作るのに重宝してました。

しかし何故かその後のWindowsには付いておらず、WindowsXPまではただ単にコピーして使っていました。

Windows7を導入した際にこれまでと同じようにWindowsXPからフォルダごとコピーしてきたのですが、起動はすれど保存したhtmlは中身が空の状態でまったく使えず。必要な時はWindowsXPのサブ機を使えばいいかと諦めていました。

とは言え、いちいちサブ機を立ち上げてメインとサブを行ったり来たりするのも面倒。
何か手はないものかとググってみるも先頭のほうに出てくるのは「無理」とか「XPモードで使う」とかばかり。それでもめげずに探していると・・・

ありました。systemフォルダのmsencode.dllをどうたらこうたら。
要はFrontPage Expressが動いているPCのsystemかsystem32フォルダからmsencode.dllを持ってきてWindows7に入れたFrontPage Expressのフォルダにコピーする。これだけ。

まだほんの少し試しただけですが問題なく動くようです。因みに64bitのWindows7でも更にほんの少しだけ試してみましたがこちらも問題なさそう。


| | コメント (10) | トラックバック (0)

64bit Windows 7でWS007SHを使う

XPモードもどきでWS007SHをモデムとして使えるようになったが、その後も情報を探していたら64bit Windows 7でAdvanced W-ZERO3ことWS011SHをモデムとして使っている方がいた。
その方法は、sysファイルは使わずinfファイルだけ書き換えて認識させるというもの。

WS011SHで出来るならWS007SHでも出来るだろうと、真似てやってみたら見事にWS007SHをモデムとして認識してダイアルアップ接続が出来た。
素晴らしい。ヘニックスさんに感謝。


■手順

1.WS007SH付属のCDにあるsymmd2.infを適当な場所にコピーして編集。
2.EC1400-41にWS007SHを繋ぐ。
3.デバイスマネージャーでWS007SHを右クリック。ドライバの更新でinfファイルがあるフォルダを指定。
4.何やら警告が出るが無視して続行。


どうせなら画像を変えたいところだが面倒だからいいか。


このデバイスは正常に動作しています。

接続先はWS007SH単体での接続先と同じでOK。

こんな簡単なことをシャープが公開しないということは何か問題があるのかも知れないが、一寸試したぶんには特に問題なさそう。このページのリロード時間もXPモードもどきと変わらない。
せっかく作った仮想マシン環境がたった1日で無用になったのは一寸複雑な気分だが。(^_^;


一応、編集したinfファイルを置いておきますので試したい方はどうぞ。→ 改造inf
但し、何があっても責任はとれませんので予めご了承ください。

| | コメント (0) | トラックバック (0)